Save My Play - https://savemyplay.com is back up – Incident details
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Get updates
All systems operational
https://savemyplay.com is back up
Resolved
Major outage
Started about 2 hours ago
July 12, 2026
Lasted about 2 hours
2:05
3:34 PM
UTC
Affected
Website + Web App (savemyplay.com)
Operational from 2:05 PM to 2:05 PM, Major outage from 2:05 PM to 3:34 PM
Updates
Resolved
July 12, 2026 at 3:34 PM
UTC
Resolved
July 12, 2026 at 3:34 PM
UTC
Website + Web App (savemyplay.com) is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
July 12, 2026 at 2:05 PM
UTC
Investigating
July 12, 2026 at 2:05 PM
UTC
UTC
UTC
UTC
UTC
UTC